1. 10 Oct, 2017 1 commit
  2. 20 Apr, 2017 7 commits
  3. 13 Apr, 2017 1 commit
  4. 24 Feb, 2017 1 commit
  5. 14 Feb, 2017 1 commit
  6. 30 Jan, 2017 1 commit
  7. 25 Jan, 2017 1 commit
  8. 24 Jan, 2017 1 commit
  9. 26 Nov, 2016 1 commit
  10. 15 Sep, 2016 1 commit
  11. 23 Jun, 2016 1 commit
  12. 01 Jun, 2016 2 commits
  13. 26 Apr, 2016 2 commits
  14. 25 Feb, 2016 1 commit
  15. 24 Nov, 2015 1 commit
  16. 23 Nov, 2015 1 commit
  17. 16 Sep, 2015 1 commit
  18. 14 Sep, 2015 1 commit
    • Marcin Cieslak's avatar
      Node 4: Use embedded OpenSSL headers first · f0a6f2e3
      Marcin Cieslak authored
      This a workaround for the compilation
      error with Node 4:
      
      ../vendor/openssl/openssl/ssl/s3_clnt.c:3262:60: error: use of undeclared identifier 'EVP_PKT_EXP'
      
      Node 4.0.0 includes openssl 1.0.2d, which
      no longer defines EVP_PKT_EXP and friends.
      
      node-gyp puts header directories supplied
      by node first, therefore OpenSSL include
      files shipped by node are used, and
      not the ones from the embedded OpenSSL
      source.
      f0a6f2e3
  19. 05 Aug, 2015 1 commit
  20. 29 Jul, 2015 1 commit
    • Tyler Wanek's avatar
      Fixed remote test error in linux / osx · 4a9cfa9c
      Tyler Wanek authored
      OSX/Linux now implement the proper behavior of libgit2 for the credentials call back. When connecting to the remote, if the credentials are bad, the remote_connect will try the credentials cb again until the credentials cb returns an unusable credentials object or the server accepts the credentials.
      
      As such, we need to put a counter on the credentials for hardcoded values, and then return nothing in the cred call back and expect to catch an error thrown by libgit.
      4a9cfa9c
  21. 28 Jul, 2015 8 commits
  22. 24 Mar, 2015 1 commit
    • John Haley's avatar
      Fix atom-shell build on windows · 2c0b94e5
      John Haley authored
      When compiling against the latest (0.22.1 currently) atom-shell
      something was defining `HAVE_POLL` which is a linux system header
      file. This was breaking the atom-shell build on windows.
      2c0b94e5
  23. 11 Mar, 2015 1 commit
  24. 17 Feb, 2015 1 commit
  25. 12 Feb, 2015 1 commit